Wednesday, December 19, 2012

Block openrc-

Problème :

During update, I have the following problem :

[blocks B      ] <sys-apps/openrc- ("<sys-apps/openrc-" is blocking sys-apps/net-tools-1.60_p20120127084908)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/net-tools-1.60_p20120127084908::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/net-tools required by @system

  (sys-apps/openrc-, installed) pulled in by
    sys-apps/openrc required by (dev-db/mysql-init-scripts-2.0_pre1-r2::gentoo, installed)
    sys-apps/openrc required by (sys-apps/baselayout-2.1-r1::gentoo, ebuild scheduled for merge)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

Solution :

Some package (net-tools) ask a new version of openrc. However, in my system, there is an old version installed (openrc- To resolv the problem, you only need to uninstall openrc :

emerge -C sys-apps/openrc

Then, install the new version of openrc :

emerge  sys-apps/openrc

No comments:

Post a Comment